WordPress不再支持PHP4和MySQL4

原文链接:PHP 4 and MySQL 4 End of Life Announcement 原文作者: Mark Jaquith

我们一向希望WordPress能运行在各种常见的服务器上。我们这么做是希望用户在选择虚拟主机时能有一些弹性。正由于这个策略,WordPress基本可以在任何地方跑起来。不过,虚拟主机平台时刻在变,所以我们不定期地会重新检查运行WordPress的基本要求。现在(当然从标题就可以看出),我们决定今后不再支持PHP4和MySQL4。

首先开发人员肯定非常关心这条消息,将于2010年晚些时候发布的WordPress 3.1将是支持PHP4的最后一个WordPress版本。

而2011年上半年将发布的WordPress 3.2,将不再支持PHP 5.2以下的版本。因为PHP 5.2是大多数WordPress用户正在使用的版本,并且从PHP 5发布以来有了大量重要的改进。同时,这也是诸如DrupalJoomla项目下次更新所支持的最低PHP版本,这两者的新版本都将在今年年底前发布。

此外,从我们的一些统计数据结果来看,这是个不错的决定。大概只有11%的WordPress跑在PHP 5.2以下,况且这其中的大部分主机也同样支持PHP 5.2,只是用户需要在后台激活升级一下。另外使用PHP 5.2以下版本的用户在今后将会逐步减少,因为当主机提供商意识到需要支持最新版本的WordPress(或者Drupal、Joomla)时,他们自然会去升级。

另外一个消息是,我们也将从WordPress 3.1之后不再支持MySQL 4。只有不到6%的WordPress用户还跑在MySQL 4上。所以,安装WordPress 3.2所需最低MySQL版本将会是5.0.15。

如果主机环境达不到这些要求,WordPress用户将不可能升级到WordPress 3.2,后台的自动升级也不会让你升级。另外,我们开发了Health Check 插件来检查你的配置是否达到要求。手动下载这个插件,或者使用这个插件安装工具。目前为止,Health Check插件只告诉你是否能够运行将来的WordPress 3.2。将来更新后,会提供关于你的服务器和WordPress安装情况的所有信息。

最后,总结下:2010年末将发布的WordPress 3.1将是支持PHP 4和MySQL 4的最后一个WordPress版本。将于2011年上半年发布的WordPress 3.2,需要PHP 5.2+和MySQL 5.0.15+。此外,如果想要检查是否达到要求,可以安装Health Check插件

 

Leave a Reply

Your email address will not be published. Required fields are marked *